Back to overview
Resolved

Madrid, Spain - Routing Server 2 degraded.

Jul 10, 2026 at 8:52pm UTC
Affected services
Madrid, Spain - Routing Server 2

Resolved
Jul 10, 2026 at 8:52pm UTC

We're currentlly expecting a heating issues on Madrid, Spain Routing server. This report will be avalible until we cool the server down.